Bug 5342 - Cannot build OpenWrap on Mono
Summary: Cannot build OpenWrap on Mono
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: Other Other
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2012-05-25 15:58 UTC by Konrad Kruczyński
Modified: 2012-05-25 17:55 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log of the build process (30.27 KB, application/octet-stream)
2012-05-25 15:58 UTC, Konrad Kruczyński
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Konrad Kruczyński 2012-05-25 15:58:36 UTC
Created attachment 1960 [details]
Log of the build process

Description of Problem:
Here is some description:
https://github.com/openrasta/openwrap/issues/320

Steps to reproduce the problem:
1. Checkout the code from https://github.com/openrasta/openwrap.git
2. Go to directory build 
3. Run xbuild


Actual Results:
Error, detailed log is in the link provided and attached as well.

Expected Results:
Fine compilation.

How often does this happen? 
Always.

Additional Information:
Comment 1 Sebastien Lambla 2012-05-25 16:22:22 UTC
specifically, the issues come from generic method resolution where restrictions are not applied the same as CSC.exe

You can see the native build of OpenWrap using xbuild on mono 2.10 on http://teamcity.caffeine-it.net as well.
Comment 2 Marek Safar 2012-05-25 17:16:41 UTC
Cannot see any compiler issue in the log. Only error I can see is

Source file `Repositories/PreAuthenticatedRepository.cs' could not be found

which does not indicate compiler bug
Comment 3 Konrad Kruczyński 2012-05-25 17:37:43 UTC
Marek, you are right, sorry for the wasted time. I've just copy pasted without investigating the issue. The build fails due to simple typo: there is PreauthenticatedRepository.cs instead of the PreAuthenticatedRepository.cs. After this change it compiles fine. The issue can be closed, I'll post the pull request to OpenWrap.