Bug 53374 - "The target "GetBuiltProjectOutputRecursive" does not exist in the project" with x-platform csproj
Summary: "The target "GetBuiltProjectOutputRecursive" does not exist in the project" w...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-15 20:23 UTC by Jerome Laban
Modified: 2017-07-10 13:09 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro case (28.93 KB, application/x-zip-compressed)
2017-03-15 20:23 UTC, Jerome Laban
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jerome Laban 2017-03-15 20:23:27 UTC
Created attachment 20366 [details]
repro case

When using the attached sample, building the iOS project fails with the following error:

error MSB4057: The target "GetBuiltProjectOutputRecursive" does not exist in the project.

This sample uses the new cross targetting feature present in MSBuild 15 and VS2017.

The android project builds fine (and selects the appropriate platform), whereas the iOS project fails.
Comment 1 Timothy Risi 2017-03-15 20:45:07 UTC
Looks like a duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=53315

*** This bug has been marked as a duplicate of bug 53315 ***
Comment 2 Jerome Laban 2017-03-16 12:25:09 UTC
The error message is the same, but the context is significantly different, which is why I did create another one. The last comment (https://bugzilla.xamarin.com/show_bug.cgi?id=53315#c3) also points to a different issue.
Comment 3 Timothy Risi 2017-03-16 18:39:16 UTC
Hadn't seen the last comment ont he other bug when I marked this one as a duplicate.  Reopening since it's a different version of VS and differnet project type
Comment 4 Adrian Alonso 2017-06-21 20:04:49 UTC
This is fixed in 15.3