Bug 5335 - Unable to get all method parameters to be on one line
Summary: Unable to get all method parameters to be on one line
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-05-25 12:04 UTC by Zack Sheppard
Modified: 2012-05-25 12:22 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Zack Sheppard 2012-05-25 12:04:46 UTC
just like it is in visual studio, I would like to have all of my method parameters just be on one line with no wrapping at all. I've tried every setting I can find and nothing works...

instead of:

Object.Method(
    param1,
    param2,
    param3
);

I want:

Object.Method(param1, param2, param3);


I had assumed the "visual studio" code formatting preset would work... but it didn't. I am formatting the document constantly and I love all the formatting except for this part. It makes it difficult for me to read. I have rejected the formatting feature entirely because of this one issue. Is there a way around it?
Comment 1 Mike Krüger 2012-05-25 12:07:27 UTC
fixed.
Comment 2 Zack Sheppard 2012-05-25 12:15:03 UTC
fixed in a new version? Mine doesn't work right now...
Comment 3 Mike Krüger 2012-05-25 12:18:24 UTC
https://github.com/mono/monodevelop

master should work.
Comment 4 Mike Krüger 2012-05-25 12:18:43 UTC
We'll do a new release soon btw.
Comment 5 Zack Sheppard 2012-05-25 12:22:35 UTC
ok thanks!