Bug 5332 - Problems referencing PLP projects from MonoTouch projects
Summary: Problems referencing PLP projects from MonoTouch projects
Status: RESOLVED DUPLICATE of bug 1309
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-05-25 11:17 UTC by Stuart Lodge
Modified: 2012-05-25 11:42 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 1309

Description Stuart Lodge 2012-05-25 11:17:57 UTC
To reproduce:
1. In MonoDevelop 3.0.2 create a new PLP project (in new solution)
2. Now choose to add a new iphone UI project
3. Add a reference for the PLP project to the UI project
4. Everything looks OK - you should currently be in "Debug" configuration
5. Choose the configuration "Debug|iPhoneSimulator" - the PLP project is greyed out with message "not built in active configuration"
6. Try to build and build fails with error message "Could not find support file" for the PLP project.

Hope that description helps - I admit I'm not 100% sure what I'm doing around iPhone project configurations!

Stuart

// =======================

This raised from email thread:

"
3. I can't work out how to reference portable library projects from
MonoTouch projects - I can add the references, but as soon as I select a
configuration like "Debug|iPhoneSimulator" then the PLP is greyed out and
"not build in active configuration" appears.

What configurations does it work with? I could have sworn this worked.

Could you submit a bug for this one, too?

I'll look into this one as well.
"
Comment 1 Mikayla Hutchinson [MSFT] 2012-05-25 11:42:06 UTC
You need to modify the solution configuration so that some project configuration of the PLP project is built in the Debug|iPhoneSimulator solution configuration.

*** This bug has been marked as a duplicate of bug 1309 ***