Bug 53191 - Unable to build WatchOS project in VS 2013 & VS 2015 in Windows 10.
Summary: Unable to build WatchOS project in VS 2013 & VS 2015 in Windows 10.
Status: RESOLVED DUPLICATE of bug 53410
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.3.1 (15.1)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-09 13:20 UTC by Saurabh Paunikar
Modified: 2017-04-12 21:12 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE logs (4.73 KB, application/x-zip-compressed)
2017-03-09 13:20 UTC, Saurabh Paunikar
Details
Attached Logs (93.54 KB, application/x-zip-compressed)
2017-03-16 12:20 UTC, Saurabh Paunikar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 53410

Description Saurabh Paunikar 2017-03-09 13:20:41 UTC
Created attachment 20247 [details]
IDE logs

Environment details: 
VS 2013: Microsoft Visual Studio Professional 2013 Version 12.0.40629.00 Update 5.
Xamarin 4.3.1.2(486e68a)
Xamarin.iOS 10.8.0.1(c3b39f2)

VS 2015: Microsoft Visual Studio Professional 2015 Version 14.0.25420.01 Update 3.
Xamarin 4.3.1.2(486e68a)
Xamarin.iOS 10.8.0.1(c3b39f2)


Steps:
1. Create an iOS Single View project.
2. Right click on solution > select Add > select New Project.
3. Select Apple Watch > create the project.
4. Under iOS app > right click on Prefrences > click on Add Refrences > click on WatchOS project & add the refrences.
5. Under WatchOS app > right click on Prefrences > click on Add Refrences > click on WatchOSExtension project & add the refrences.
6. Add the required certificates under Properties section of all 3 projects.
7. Set the project as Start Up of Watch OS project.
8. Now click on run button on actual device & observe.

Actual: Build is not getting deployed. Error: 
visual studio 2013/Projects/MainApp/WatchOSApp1/WatchOSApp1.WatchOSExtension/obj/iPhone/Debug/Entitlements.xcent: cannot read entitlement data C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets 1699 3 WatchOSApp1.WatchOSApp

Expected: It should run successfully in WatchOS Actual Device.

Screencast link: https://www.screencast.com/t/mcxI1wph3


Note: It is working fine on actual device in XS(Mac), but not working fine in VS 2013 & VS 2015(Windows 10).
Comment 1 Emanuel 2017-03-10 14:47:06 UTC
@Saurabh, I have a couple of doubts/requests:
- Why did you delete the "Custom entitlements" default value (Entitlements.plist) and leave it blank for watchOS app and extension?
- Could you attach the Mac side logs?
- Could you attach the detailed build output?

Thanks!
Comment 2 Saurabh Paunikar 2017-03-16 12:20:06 UTC
Created attachment 20379 [details]
Attached Logs

@ Emanuel, I have tried both ways(with and without Entitlements.plist). I am getting same Issue.
Kindly refer below screencast 

https://www.screencast.com/t/q3j09UBdf


Please find attached document which contains
-Error logs
-Detailed output logs
-VS Ide logs
-Mac side logs(XS Ide of used Mac Agent) 
-Error ScreenShot

kindly advice if anything else is required or we are missing out anything
Comment 3 Luis Aguilera 2017-03-17 16:00:50 UTC
@saurabh when answering a bug in NEEDSINFO state, please remember to change the state back to either NEW or CONFIRMED.
Comment 4 Emanuel 2017-04-12 21:12:00 UTC

*** This bug has been marked as a duplicate of bug 53410 ***