Bug 53175 - Creating a Xamarin Forms app in VS 2017 RTM fails to create the UWP version
Summary: Creating a Xamarin Forms app in VS 2017 RTM fails to create the UWP version
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Templates ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Pierce Boggan [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-09 00:04 UTC by unnir@microsoft.com
Modified: 2017-03-15 17:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description unnir@microsoft.com 2017-03-09 00:04:17 UTC
Install Visual Studio 2017 RTM with the Xamarin and UWP workloads
Blow away the Nuget cache located at C:\Users\username\.nuget (this is an important step)
Create new Xamarin Forms apps - in the wizard, select PCL instead of shared projects

Observed: Cannot create the UWP version because package restore fails for the Universal Windows Platform .NET meta-package 5.1.0

Expected: We should be using 5.2.2, and this should work just like it does for the Shared project version of this template (where things work fine).
Comment 1 Cody Beyer (MSFT) 2017-03-09 00:13:19 UTC
Full error message:

>---------------------------
>Microsoft Visual Studio
>---------------------------
>Package Installation Error

>Could not add all required packages to the project. The following packages 
>failed to install from 'C:\Program Files (x86)\Microsoft SDKs\NuGetPackages':



>Microsoft.NETCore.UniversalWindowsPlatform.5.1.0 : Package restore failed. 
>Rolling back package changes for 'App4.UWP'.
>---------------------------
>OK   
>--------------------------