Bug 53164 - msbuild-mac tests should be running with msbuild in addition to xbuild
Summary: msbuild-mac tests should be running with msbuild in addition to xbuild
Status: RESOLVED UPSTREAM
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: MSBuild ()
Version: Master
Hardware: PC Mac OS
: High normal
Target Milestone: 15.7
Assignee: Ankit Jain
URL:
Depends on:
Blocks:
 
Reported: 2017-03-08 19:47 UTC by Chris Hamons
Modified: 2018-05-21 20:20 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Chris Hamons 2017-03-08 19:47:44 UTC
This is a tracking bug for updating the tests to support msbuild.

There are at least two tests that will be PR'ed soon that are disabled for now until this is fixed.

They can not be enabled yet, so we don't have the infrastructure to build msbuild tests without using the global install, which does not work on bots.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2017-03-09 06:33:34 UTC
I think the only thing you need to do is to add /p:TargetFrameworkRootPath=/path/to/xamarin-macios/_ios-build/Library/Frameworks/Mono.framework/External/xbuild-frameworks/ to the msbuild command line.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2017-03-09 06:34:00 UTC
Well, ../_mac-build/.. in the case of XM of course
Comment 3 Chris Hamons 2017-08-02 18:28:30 UTC
When doing this, make sure the mmp tests are also updated (99% sure same code).
Comment 4 Ankit Jain 2017-08-02 18:30:10 UTC
AFAICS, this can actually be attempted now. When I was trying to port the tests earlier, we didn't have any support for the older xbuild assemblies (v4.0/v12.0), but we do now. IOW, you should be able to just run the same thing with msbuild instead of xbuild. And let me know of any issues that you hit.
Comment 6 Chris Hardy [MSFT] 2017-09-21 14:52:47 UTC
Moving out to 15.6
Comment 7 Chris Hamons 2017-09-27 19:36:03 UTC
Currently blocked on ability to redirect msbuild to use local targets/tasks.
Comment 8 Vincent Dondain [MSFT] 2018-05-21 20:20:25 UTC
Tracked here https://github.com/xamarin/xamarin-macios/issues/4110