Bug 53133 - [Cycle 9] "Xamarin for Visual Studio" and "Xamarin.Forms Templates" extensions are marked as "[Experimental]" under "Tools > Extensions and Updates" in VS 2015
Summary: [Cycle 9] "Xamarin for Visual Studio" and "Xamarin.Forms Templates" extension...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.3.0 (C9)
Hardware: PC Mac OS
: Low minor
Target Milestone: 15.3
Assignee: Bugzilla
URL:
Depends on:
Blocks: 53130
  Show dependency tree
 
Reported: 2017-03-07 21:47 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2017-07-14 06:23 UTC (History)
5 users (show)

Tags: Cycle9R
Is this bug a regression?: Yes
Last known good build: Cycle 8 SR 2 (XamarinVS 4.2.2.11)


Attachments
BAD screenshot showing "[Experimental]" label in Cycle 9 (92.92 KB, image/png)
2017-03-07 21:47 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
GOOD screenshot showing _no_ "[Experimental]" label in Cycle 8 (91.66 KB, image/png)
2017-03-07 21:48 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
GOOD screenshot showing _no_ "[Experimental]" label in VS 2013 with Cycle 9 (123.91 KB, image/png)
2017-03-07 22:08 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
Screenshot during verification (91.27 KB, image/png)
2017-07-14 06:23 UTC, Prasad Raghorte
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2017-03-07 21:47:44 UTC
Created attachment 20193 [details]
BAD screenshot showing "[Experimental]" label in Cycle 9

[Cycle 9] "Xamarin for Visual Studio" and "Xamarin.Forms Templates" extensions are marked as "[Experimental]" under "Tools > Extensions and Updates"




## Regression status: regression in Cycle 9 compared to Cycle 8

BAD:   XamarinVS 4.3.0.784 (73f58d6)
GOOD:  XamarinVS 4.2.2.11  (00fa5cc)




## Steps followed to test

1. Start with a clean Windows 10, Visual Studio 2015 Update 3 image.

2. Install Xamarin 4.3.0.784 Cycle 9 or 4.2.2.11 Cycle 8.

3. Open Visual Studio, open the "Tools > Extensions and Updates" dialog, and navigate to "Installed > All".




## BAD results in Cycle 9

The following 2 extensions are marked as "[Experimental]".

- Xamarin for Visual Studio
- Xamarin.Forms Templates

(See also the attached "BAD" screenshot.)




## GOOD results in Cycle 8

Neither of the 2 extensions is marked as "[Experimental]".

(See also the attached "GOOD" screenshot.)




## Testing environment version info (brief)

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01586

Windows 10 (64-bit) Version 1607 (OS Build 14393.321)
US English locale, US eastern time zone
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2017-03-07 21:48:25 UTC
Created attachment 20194 [details]
GOOD screenshot showing _no_ "[Experimental]" label in Cycle 8
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2017-03-07 21:51:03 UTC
## Tallying reports for bookkeeping

1 user: Bug 53008, Comment 6 (2017-03-05)
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2017-03-07 22:08:28 UTC
Created attachment 20195 [details]
GOOD screenshot showing _no_ "[Experimental]" label in VS 2013 with Cycle 9

## Additional result: VS 2013 with Cycle 9 is OK

Although this issue (or something similar to it) does affect VS 2017 (Bug 53130), it does not affect VS 2013.
Comment 5 Prasad Raghorte 2017-07-14 06:23:15 UTC
Created attachment 23548 [details]
Screenshot during verification

Verified this defect on VS 2015 xamarin version :4.6.0.289 (9b1a9b2)
Build info : https://gist.github.com/raghorteprasad/c92afa139b28e131c4e16379152f7d2e

This is fixed and working as expected. Please find attached screenshot.