Bug 53072 - xamarin-component.exe restore "path.sln" outputs that component is restored, but folder doesn't appear.
Summary: xamarin-component.exe restore "path.sln" outputs that component is restored, ...
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Generation ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bill Holmes
URL:
Depends on:
Blocks:
 
Reported: 2017-03-06 13:50 UTC by Ivan Shakhov
Modified: 2017-09-27 14:34 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
my xamarin-component (2.18 MB, application/x-msdownload)
2017-03-06 13:50 UTC, Ivan Shakhov
Details
my corrupted xam (2.80 MB, application/zip)
2017-03-06 13:51 UTC, Ivan Shakhov
Details
solution (19.06 KB, application/x-zip-compressed)
2017-03-06 13:52 UTC, Ivan Shakhov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ivan Shakhov 2017-03-06 13:50:24 UTC
Created attachment 20149 [details]
my xamarin-component

It seems that you need to corrupt one of the components in %localappdata%\Xamarin\Cache\Components
And then attempt to restore will give you the following

C:\Program Files\Far Manager>"C:\Build Agent\work\d7974c1f8dd35a08\Bin.ReSharperHost\xamarin-component.exe" restore C:\t
INFO (restore): Computed cookie jar path: C:\Users\builduser.WINDOWS-OE1VE3K\.xamarin-credentials
INFO (restore): [*] Restoring azure-mobile-services v1.3.1
INFO (restore): [*] Successfully restored azure-mobile-services v1.3.1

but no Components folder will be created near the sln file.
Comment 1 Ivan Shakhov 2017-03-06 13:51:19 UTC
Created attachment 20150 [details]
my corrupted xam
Comment 2 Ivan Shakhov 2017-03-06 13:52:25 UTC
Created attachment 20151 [details]
solution
Comment 3 Bill Holmes 2017-09-27 14:34:40 UTC
The latest version of Xamarin Component resolves this issue.  

https://www.nuget.org/packages/XamarinComponent/1.1.0.65

There is now an error message alerting thus user of the failed unzip.