Bug 53070 - [Xamarin VS][4.3.1.2][Windows10][R-100%] Unable to deploy tvOS application on Apple TV device from VS.
Summary: [Xamarin VS][4.3.1.2][Windows10][R-100%] Unable to deploy tvOS application on...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: 15.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-06 11:36 UTC by Jacky Waswani
Modified: 2017-04-10 09:09 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attachment as screenshot & logs. (874.41 KB, application/zip)
2017-03-06 11:36 UTC, Jacky Waswani
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jacky Waswani 2017-03-06 11:36:52 UTC
Created attachment 20147 [details]
Attachment as screenshot & logs.

Environment: 
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01055
Xamarin   4.3.1.2 (3b21f70)
Xamarin.Android   7.1.99.93 (486e68a)
Xamarin.iOS   10.8.0.1 (c3b39f2)

Steps to Reproduce
1-Pull the code from QA repo.
2-Open CrossPlatformDebugging project > select the tvOSDebugging as Start Up project.
3-Right click on tvOSDebugging > select 'Properties' > select 'iOS Bundle Signing' options.
4-Select provisioning profile & certificate.

Actual
-We are unable to run the tvOS application on Apple TV using VS on Windows 10. While which worked for actual Apple TV via XS(mac).
-We have done above scenario using our provisioning profile.

Expected
-It should work on actual Apple TV for VS of Windows 10.
Comment 1 Emanuel 2017-03-10 15:36:08 UTC
@Jacky, could you attach the Mac logs and the Detailed build output?

You can get the Mac logs from Help -> Xamarin -> Zip Logs...
Comment 2 Gaurav Ganorkar 2017-03-16 12:15:55 UTC
Verified this test on build versions ,
For Windows : 
Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3
Microsoft .NET Framework
Version 4.6.01055

Xamarin   4.3.1.39 (a70e3a1)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   7.2.0.1 (ff38526)
Visual Studio extension to enable development for Xamarin.Android.

Xamarin.iOS   10.8.0.17 (49a63dc)
Visual Studio extension to enable development for Xamarin.iOS.

For MacAgent:

Xamarin Studio Enterprise
Version 6.3 (build 834)
Installation UUID: 69f4e361-6bd8-4410-844f-3bd15ac993d7
Runtime:
 Mono 4.8.0 (mono-4.8.0-branch/8f6d0f6) (64-bit)
 GTK+ 2.24.23 (Raleigh theme)

Xamarin.iOS 

Version: 10.8.0.20 (Visual Studio Enterprise Trial)
Hash: f94cf26
Branch: d15-1
Build date: 2017-03-14 12:37:51-0400

Xamarin.Mac 
Version: 3.2.0.20 (Visual Studio Enterprise Trial)

Xamarin.Android
Version: 7.2.0.2 (Visual Studio Enterprise Trial)

Operating System 
Mac OS X 10.12.0

Now it is working fine & as expected. We can resolve the issue.
Comment 3 Aman Dharwal 2017-03-31 09:02:28 UTC
This issue is Resolved