Bug 53065 - ProgressBar in ViewCell does not update on UWP
Summary: ProgressBar in ViewCell does not update on UWP
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.3
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-03-05 22:39 UTC by Matthew Richardson
Modified: 2017-03-14 17:33 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Demo project with side-by-side comparison showing bug (268.26 KB, application/zip)
2017-03-05 22:39 UTC, Matthew Richardson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Matthew Richardson 2017-03-05 22:39:22 UTC
Created attachment 20139 [details]
Demo project with side-by-side comparison showing bug

When using a nested XAML view inside a ViewCell, ProgressBar does not work correctly on UWP.

Eg. We have a ListView with a custom ViewCell containing a nested XAML view with a ProgressBar.
The value in the view model is being changed (through a binding) and the property change notification is firing, but the progress bar is not updated on UWP.
Note: Works fine on Android, iOS.

The problem only occurs when using a nested XAML view inside a ViewCell.
If the progress bar is included directly within the ViewCell, everything works fine.
ie.

ViewCell --> Nested XAML View --> ProgressBar --> Progress bar is not updated.
ViewCell --> ProgressBar --> Progress bar is updated.

Please see sample solution for a side-by-side demo.
Comment 1 Paul DiPietro [MSFT] 2017-03-06 14:34:43 UTC
I just posted on the forums in relation to this issue, but it appears as if this is working on the nightly. Please feel free to leave some feedback here before I make any further changes on this as necessary.
Comment 2 Matthew Richardson 2017-03-06 23:13:29 UTC
I can confirm the issue with the demo project is resolved with the latest XF 2.3.4 nightly build.  I haven't yet tested with our production app as this is still sitting on XF 2.3.3, but don't anticipate any issues.

Please feel free to mark this issue as resolved for now, and if there are any future issues it can be re-opened or re-ticketed.

Many thanks once again.