Bug 5302 - [MMP] MonoMac solution with the Mono Runtime included fails to build.
Summary: [MMP] MonoMac solution with the Mono Runtime included fails to build.
Status: CLOSED INVALID
Alias: None
Product: MonoMac
Classification: Desktop
Component: Bindings ()
Version: unspecified
Hardware: Macintosh Windows
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-05-24 11:00 UTC by PJ
Modified: 2012-05-24 11:32 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED INVALID

Description PJ 2012-05-24 11:00:31 UTC
Summary: After checking the box for 'Include Mono Runtime in the application bundle', when build the solution error appears, i.e Merging Mono Runtime failed. See the log for details.

Steps to reproduce:
1. Create a new MonoMac project.
2. Open the project options.
3. Navigate to Mac OS X Packaging
4. Check the box 'Include Mono Runtime in the application bundle'
5. Build the project.
6. Observe that error appears.

Actual result: After checking the box for 'Include Mono Runtime in the application bundle', when build the solution error appears, i.e Merging Mono Runtime failed. See the log for details.

Expected result: After checking the box for 'Include Mono Runtime in the application bundle', when build the solution error should not appear and the project should build and run successfully.

Supplement information:
https://gist.github.com/2780164

Environment details:
Mac 10.7.3 Lion (happens on SL too though)
MD 3.0.2
M4A 4.2.2
MT 5.2.12
Comment 1 PJ 2012-05-24 11:17:10 UTC
Looks like they have the MRE instead of the MDK. Will verify in the office - lowering the severity for now.