Bug 53014 - Xamarin.Auth displays multiple alert boxes
Summary: Xamarin.Auth displays multiple alert boxes
Status: ASSIGNED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Miljenko Cvjetko Mel
URL:
Depends on:
Blocks:
 
Reported: 2017-03-03 13:15 UTC by John Hardman
Modified: 2017-07-23 09:01 UTC (History)
3 users (show)

Tags: Xamarin.Auth Alert loop
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 53014 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
ASSIGNED

Description John Hardman 2017-03-03 13:15:45 UTC
As per the thread at https://forums.xamarin.com/discussion/5866/xamarin-auth-and-infinite-error-alerts Xamarin.Auth seems to get into an infinite loop displaying alert boxes on both Android and iOS physical devices. I have seen this with various messages when setting up Xamarin.Auth for different servers (e.g. "We only support a response type of code but you passed token" and "Unexpected character '<'. At line 1, column 0"). This bug report is about the infinite loop, the cause of those messages will be reported separately after further investigation.
Comment 1 gabsikarim 2017-07-23 09:01:43 UTC
Any solution to this yet?