Bug 5301 - Problem with vs2010 plugin
Summary: Problem with vs2010 plugin
Status: RESOLVED DUPLICATE of bug 5063
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-05-24 10:21 UTC by Javier Rodríguez
Modified: 2016-08-03 15:24 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 5063

Description Javier Rodríguez 2012-05-24 10:21:35 UTC
VS2010 load without problems.

If I go to options-> mono for android. no properties pages are shown and a error appear:

The packet Mono.Android.VisualStudio.MonoAndroidPackage, .... don't loaded correctly.

in activitylog.xml


287 ERROR SetSite failed for package [Mono.Android.VisualStudio.MonoAndroidPackage, Mono.Android.VisualStudio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=370d3ce848a5d21a] {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6} 80131537 VisualStudio 2012/05/24 14:08:45.915 
288 ERROR End package load [Mono.Android.VisualStudio.MonoAndroidPackage, Mono.Android.VisualStudio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=370d3ce848a5d21a] {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6} 80131537 VisualStudio 2012/05/24 14:08:45.921 
289 Warning Package failed to load; error message suppressed by skip flag {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6}  VisualStudio 2012/05/24 14:08:45.922 
290  Entering function CVsPackageInfo::HrInstantiatePackage {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6}  VisualStudio 2012/05/24 14:08:45.926 
291  Begin package load [Mono.Android.VisualStudio.MonoAndroidPackage, Mono.Android.VisualStudio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=370d3ce848a5d21a] {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6}  VisualStudio 2012/05/24 14:08:45.927 
292 ERROR CreateInstance failed for package [Mono.Android.VisualStudio.MonoAndroidPackage, Mono.Android.VisualStudio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=370d3ce848a5d21a] {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6} 80131604 VisualStudio 2012/05/24 14:08:45.929 
293 ERROR End package load [Mono.Android.VisualStudio.MonoAndroidPackage, Mono.Android.VisualStudio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=370d3ce848a5d21a] {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6} 80004005 - E_FAIL VisualStudio 2012/05/24 14:08:45.930 
294 Warning Package failed to load; error message suppressed by skip flag {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6}  VisualStudio 2012/05/24 14:08:45.931 


The same if I try to create a MfA project.
Comment 1 Jonathan Pobst 2012-05-24 10:39:07 UTC
This is fixed for 4.2.2, which should be coming out later today.

*** This bug has been marked as a duplicate of bug 5063 ***
Comment 2 Javier Rodríguez 2012-05-24 10:49:56 UTC
ok thanks!