Bug 52969 - Xamarin profiler not working from Visual studio enterprise 2015 update 3
Summary: Xamarin profiler not working from Visual studio enterprise 2015 update 3
Status: RESOLVED ANSWERED
Alias: None
Product: Profiler
Classification: Xamarin
Component: iOS ()
Version: 1.2.x
Hardware: PC Windows
: High normal
Target Milestone: 15.1
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2017-03-02 13:07 UTC by nikamvd
Modified: 2017-03-03 06:13 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description nikamvd 2017-03-02 13:07:23 UTC
# Steps to reproduce
1. Open Xamarin.iOS project in visual studio enterprise 2015 update 3.
2. Click Analyze -> Xamarin Profiler -> select Allocations -> Click choose
3. Allocations region shows "Please wait..." progress indefinitely.

The profiler log is as below-
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6779] ##########################################
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6789] # Xamarin Profiler version -  1.2.0.6
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6789] #  * Arch x86_64
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6789] ##########################################
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.7340] initializing android platform
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.7340] initializing ios platform
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.7580] initializing mlpd platform
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:57:39.2010] Initializing profiling...
XamarinProfiler.Windows.MainWindow Information: 0 : [2017-03-02 17:57:39.2390] StartRecording for MyApp.app
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:57:40.1389] Connecting to [MyMacMachineIP] as [MyMacMachineHostName]
Xamarin.Messaging.Client.MessagingClient Error: 0 : An error occured on client profilerXYZ while executing a post for topic xma/clients
System.TimeoutException: The operation has timed out.
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__23`2.MoveNext()
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:58:40.2379] Starting MyApp.app on iPhone 6s iOS 10.2 | iOS 10.2
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:58:40.2441] Starting listener on port 52803
Xamarin.Messaging.Client.MessagingClient Error: 0 : An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/start-profiling
Xamarin.Messaging.Exceptions.ReceiverNotFoundException: No receiver was found for topic xp/1.2.0.6/start-profiling
   at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__23`2.MoveNext()
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0578] error occured on run MyApp.app System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0578] error occured on run MyApp.app System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:59:11.0588] Sorry, something went wrong trying to run MyApp.app: System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.Core.ProfileIosXmaRun Information: 0 : [2017-03-02 17:59:11.0618] Stopping remote application
XamarinProfiler.Windows.MainWindow Error: 0 : [2017-03-02 17:59:11.0699] Error occured on run MyApp.app: System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.MainWindow Error: 0 : [2017-03-02 17:59:11.0699] Error occured on run MyApp.app: System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
Xamarin.Messaging.Client.MessagingClient Error: 0 : An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling
Xamarin.Messaging.Exceptions.ReceiverNotFoundException: No receiver was found for topic xp/1.2.0.6/stop-profiling
   at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__23`2.MoveNext()
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0774] error occured on run MyApp.app An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0774] error occured on run MyApp.app An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:59:11.0774] Sorry, something went wrong trying to run MyApp.app: An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling



# Expected behavior
Xamarin Profiler should start profiling my ios app

# Actual behavior
Not able to use Xamarin Profiler from Visual studio

# Supplemental info (logs, images, videos)
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6779] ##########################################
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6789] # Xamarin Profiler version -  1.2.0.6
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6789] #  * Arch x86_64
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.6789] ##########################################
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.7340] initializing android platform
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.7340] initializing ios platform
XamarinProfiler.Core.Profiler Information: 0 : [2017-03-02 17:57:31.7580] initializing mlpd platform
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:57:39.2010] Initializing profiling...
XamarinProfiler.Windows.MainWindow Information: 0 : [2017-03-02 17:57:39.2390] StartRecording for MyApp.app
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:57:40.1389] Connecting to [MyMacMachineIP] as [MyMacMachineHostName]
Xamarin.Messaging.Client.MessagingClient Error: 0 : An error occured on client profilerXYZ while executing a post for topic xma/clients
System.TimeoutException: The operation has timed out.
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__23`2.MoveNext()
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:58:40.2379] Starting MyApp.app on iPhone 6s iOS 10.2 | iOS 10.2
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:58:40.2441] Starting listener on port 52803
Xamarin.Messaging.Client.MessagingClient Error: 0 : An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/start-profiling
Xamarin.Messaging.Exceptions.ReceiverNotFoundException: No receiver was found for topic xp/1.2.0.6/start-profiling
   at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__23`2.MoveNext()
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0578] error occured on run MyApp.app System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0578] error occured on run MyApp.app System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:59:11.0588] Sorry, something went wrong trying to run MyApp.app: System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.Core.ProfileIosXmaRun Information: 0 : [2017-03-02 17:59:11.0618] Stopping remote application
XamarinProfiler.Windows.MainWindow Error: 0 : [2017-03-02 17:59:11.0699] Error occured on run MyApp.app: System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
XamarinProfiler.Windows.MainWindow Error: 0 : [2017-03-02 17:59:11.0699] Error occured on run MyApp.app: System.Exception: didn't get a connection from the Mac agent after 30 seconds, terminating
Xamarin.Messaging.Client.MessagingClient Error: 0 : An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling
Xamarin.Messaging.Exceptions.ReceiverNotFoundException: No receiver was found for topic xp/1.2.0.6/stop-profiling
   at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__23`2.MoveNext()
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0774] error occured on run MyApp.app An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Error: 0 : [2017-03-02 17:59:11.0774] error occured on run MyApp.app An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling
XamarinProfiler.Windows.ViewModels.ProgressReport.ReportViewModel Information: 0 : [2017-03-02 17:59:11.0774] Sorry, something went wrong trying to run MyApp.app: An error occured on client profilerXYZ while executing a post for topic xp/1.2.0.6/stop-profiling


# Test environment (full version information)
Windows - 10
Visual studio enterprise 2015 Update 3
Xamarin 4.2.2.11
Xamarin.iOS 10.3.1.8

Mac-
Mac Mini
OS X EI Capitan
2.6 GHz Intel core i5
8 GB RAM
Comment 1 Rodrigo Moya 2017-03-02 16:09:09 UTC
You need to upgrade XamarinVS to C9 (stable channel), that should fix the 1st connection problem. So please try that and let me know if it fixes it for you
Comment 2 nikamvd 2017-03-03 06:13:05 UTC
Thank you very much. Updating XamarinVS to C9 (stable channel) fixed my problem.