Bug 5294 - Copying partial value does not work
Summary: Copying partial value does not work
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 3.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-05-23 15:54 UTC by Sebastien Pouliot
Modified: 2012-05-25 14:23 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastien Pouliot 2012-05-23 15:54:08 UTC
Double click on a watch (or a local) and select a portion of the string value. Do a command+C (copy) then paste the output into the editor.

Actual result: the full Value is pasted

Expected result: the selected portion of value should be pasted


Note: expanding (zoom icon / dialog) the string allow you to copy/paste correctly but it takes a lot more time.
Comment 1 Jeffrey Stedfast 2012-05-25 14:23:35 UTC
fixed in git master