Bug 52919 - Archive Manager ignores regional settings displaying package details
Summary: Archive Manager ignores regional settings displaying package details
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.2
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-03-01 00:08 UTC by Mikhail Melnik
Modified: 2017-05-04 10:02 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
IDE logs and Screenshot (51.35 KB, application/x-zip-compressed)
2017-04-26 13:17 UTC, Saurabh Paunikar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mikhail Melnik 2017-03-01 00:08:02 UTC
Archive Manager uses US regional settings to display archive's date ignoring system settings.

For example for the package from March 1st on Windows with Australian regional settings it shows `Creation Date: 3/1/2017` while `1/3/2017` is expected.


Xamarin   4.3.0.784 (73f58d6)
Xamarin.Android   7.1.0.41 (9578cdc)
Xamarin.iOS   10.4.0.123 (35d1ccd)
Comment 1 Jose Gallardo 2017-03-02 14:54:07 UTC
Setting Target Milestone to 15.2.
Thanks for reporting.
Comment 3 Saurabh Paunikar 2017-04-26 13:16:39 UTC
As per Indian Standard time shown in Cmd it should show in pattern "The current date is: 26-04-2017" but its showing as "4/26/2017 ". Issue still persists marking it as reopen

## Build info : https://gist.github.com/saurabh-paunikar/0c2748bd1ae59284ac6c22c37ac8475d

## screencast : 
https://www.screencast.com/t/in1vFn2n7

## attached IDE logs and screenshots
Comment 4 Saurabh Paunikar 2017-04-26 13:17:16 UTC
Created attachment 21804 [details]
IDE logs and Screenshot
Comment 5 Jose Gallardo 2017-04-27 13:48:32 UTC
Fixed on

d15-2 commit: 6dc526ce5fd393f76e5e5d52e09503a21461d110 (XVS 4.5.0.428)
master commit: 6bb76093565a59c9e14dd4771a8ac8b1ccadf581 (XVS 4.6.0.30)
Comment 6 Aman Dharwal 2017-05-04 10:02:10 UTC
Hello,
Verified this bug on latest build :-
Xamarin   4.5.0.440 (910625d)
Xamarin.Android   7.3.0.13 (448f54f)
Xamarin.iOS   10.10.0.30 (30b6e87)

Build Information :-
https://gist.github.com/anonymous/a93840d6cf5b775a0ba047bc97dc7fbc

Screencast link :-

http://www.screencast.com/t/mXmb12qDrB

Hence marking the bug as verified

Thanks.