Bug 52918 - iO designer test suite hangs with latests mono/2017-02
Summary: iO designer test suite hangs with latests mono/2017-02
Status: RESOLVED DUPLICATE of bug 52513
Alias: None
Product: iOS
Classification: Xamarin
Component: Infrastructure (internal) ()
Version: unspecified
Hardware: PC Mac OS
: High major
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-28 23:46 UTC by Rodrigo Kumpera
Modified: 2017-03-01 05:22 UTC (History)
8 users (show)

Tags: 2017-02
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 52513

Description Rodrigo Kumpera 2017-02-28 23:46:56 UTC
When using https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=4354&host_id=387&revision_id=862202

It triggers a hang in the test-ios-sim_xcode81_10-1_EN	 step. It's not clear what exactly is hanging here.
Comment 1 Rodrigo Kumpera 2017-02-28 23:49:08 UTC
Hey Guys,

Can you work on what the issue is here?
Comment 2 Vlad Brezae 2017-03-01 00:02:42 UTC
This looks like a duplicate of #52513. I'm expecting that bug to have been fixed by my commit from the other day that I mentioned there. I think we should wait if we see new hangs like that in the wild.
Comment 3 Alan McGovern 2017-03-01 05:22:06 UTC
Let's mark it as a dupe then! If your fix doesn't solve the hang then it's most likely to be a different issue in mono as this step doesn't hang with 4.8 or older.

*** This bug has been marked as a duplicate of bug 52513 ***