Bug 52833 - Unable to find my self created folders in Resources
Summary: Unable to find my self created folders in Resources
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-27 07:14 UTC by Aditya
Modified: 2017-05-24 13:50 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Aditya 2017-02-27 07:14:14 UTC
I created a "menu" folder within my "Resources" folder, but when I try to find the "menu" folder in my activity code, i.e. <(inflater.Inflate(Resources.menu.menu_main, menu))>, I get an error that "Resources does not contain a definition for 'menu'". I have been getting this error for the past couple of weeks.

Would really be grateful for all the help on this!


Thanks and Regards,
Aditya
Comment 1 dean.ellis 2017-03-03 13:08:32 UTC
Can you post the contents of the menu_main.xml file which you have in the menu folder? 
I also assume you added that file to the project with an AndroidResource build action?
Comment 2 Juan Marcelo Tondato 2017-05-24 13:50:01 UTC
Hi,
As we've introduced several improvements around this area, I'll mark the bug as resolved fixed.
Please feel free to reopen it if you can still reproduce the issue with current bits.
Thanks!