Bug 52666 - Control is created using Dispatcher is not visible initially in Xamarin.Forms.UWP
Summary: Control is created using Dispatcher is not visible initially in Xamarin.Forms...
Status: RESOLVED UPSTREAM
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-02-22 12:41 UTC by Sheik Syed
Modified: 2017-06-16 20:11 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Control is created using Dispatcher is not visible initially in Xamarin.Forms.UWP (78.87 KB, application/x-zip-compressed)
2017-02-22 12:41 UTC, Sheik Syed
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description Sheik Syed 2017-02-22 12:41:39 UTC
Created attachment 19902 [details]
Control is created using Dispatcher is not visible initially in Xamarin.Forms.UWP

We have created the control using Dispatcher in native UWP. We have added this control as item in ListView using ItemTemplate. When run the application,control is not visible on loading time. But control is visible after resize the window. 

We have reproduced this problem in simple sample, please find the attached sample.Also,if you create any Shapes(like Rectangle) instead of control in dispatcher, then it visible on loading time. 


** Steps to Reproduce **

1. Run the attached sample. 
2. control will not visible initially.
3. Resize the window the control will be visible.

Note: problem reproduced only when add control in ListView.
Comment 1 Paul DiPietro [MSFT] 2017-02-22 19:34:16 UTC
See the answer in https://bugzilla.xamarin.com/show_bug.cgi?id=38092, which I just tested and displays the control.
Comment 2 Sheik Syed 2017-03-05 19:18:02 UTC
Hi Paul, 

Provided workaround solution is not possible in custom control which is created in native UWP. Since we didn't refer the xamarin assemblies in native UWP. We can visible the shapes on loading time, only problem happened for control when using in dispatcher. Could you fix this issue ?