Bug 52661 - [Cycle 9] "Not Responding" appears in VS window title when the new "Installing Android components..." dialog is initiated by building a new template project (but not when reopening an existing project)
Summary: [Cycle 9] "Not Responding" appears in VS window title when the new "Installin...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-22 05:42 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2017-07-28 12:51 UTC (History)
6 users (show)

Tags: Cycle9KI
Is this bug a regression?: No
Last known good build:


Attachments
Screenshot "Not Responding" title bar when installing Android components (550.52 KB, image/png)
2017-02-22 05:42 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
Screenshot of temporary "Progress in this operation" window when installing Android components (634.36 KB, image/png)
2017-02-22 05:44 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2017-02-22 05:42:21 UTC
Created attachment 19899 [details]
Screenshot "Not Responding" title bar when installing Android components

[Cycle 9] "Not Responding" appears in VS window title when the new "Installing Android components..." dialog is initiated by building a new template project (but not when reopening an existing project)




## Steps to replicate

1. Delete any expanded folders "Xamarin.Android.Support.*" that are present in "%LOCALAPPDATA%\Local\Xamarin".

2. Create a new "Visual C# > Cross-Platform > Cross Platform App (Xamarin.Forms or Native) > Blank App, Xamarin.Forms, Shared Project".

3. Build the Android project.




## "Bad" Results when building a brand new project

- The Visual Studio UI is non-responsive for as long as the "Installing Android components..." dialog is running.  (See attached screen grab.)

- If you wait a while, a new dialog appears temporarily that says "Progress in this operation is taking a long time and Visual Studio may be in a hung state."  (See screen grab attached in the next comment.)  The dialog automatically closes after a short time and the "Installing Android components..." process eventually finishes successfully.




## "Good" Results if you close the project, again remove the expanded folders as in step 1, and then reopen the project

If you open an _existing_ Android project that uses the Android Support libraries, the "Installing Android components..." dialog appears in the same way as in the "bad" case, but the Visual Studio UI remains _responsive_ throughout the process.




## Testing environment info (brief)

Microsoft Visual Studio Enterprise 2015
Version 14.0.25431.01 Update 3

XamarinVS 4.3.0.781 (6714407)

Windows 10 (64-bit) Version 1607 (OS Build 14393.321)
US English locale, US Eastern time zone
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2017-02-22 05:44:26 UTC
Created attachment 19900 [details]
Screenshot of temporary "Progress in this operation" window when installing Android components
Comment 2 Juan Marcelo Tondato 2017-03-09 16:34:04 UTC
We can corroborate that the thread UI freezes during the build process, but does not imply a block in VS. The user can cancel the download process or wait at the end of the construction to use VS.

We are moving it to a future cycle to improve this user experience.
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2017-03-23 22:35:34 UTC
## Typo correction for Comment 0

"%LOCALAPPDATA%\Local\Xamarin"

should instead be:

"%LOCALAPPDATA%\Xamarin"
Comment 4 xamarin-release-manager 2017-07-24 13:54:18 UTC
Fixed in version 4.8.0.63 (master)

Author: Juan Marcelo Tondato
Commit: 4c52b8fb7d394cb49d4bc2f906923af569ff9c63 (xamarin/XamarinVS)