Bug 52513 - mtouch times out with mono-2017-02
Summary: mtouch times out with mono-2017-02
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: Infrastructure (internal) ()
Version: master
Hardware: PC Mac OS
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Ludovic Henry
URL:
: 52918 ()
Depends on:
Blocks:
 
Reported: 2017-02-14 23:11 UTC by Rodrigo Kumpera
Modified: 2017-03-02 21:54 UTC (History)
5 users (show)

Tags: 2017-02
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Rodrigo Kumpera 2017-02-14 23:11:01 UTC
While testing mono-2017-02 with Xamarin Studio, the test-ios-sim_xcode81_10-1_EN step timed out due to:

mtouch didn't complete within 30s of the simulator app exiting. Touch.Server will exit anyway.

You can see if from this run: https://wrench.internalx.com/Wrench/ViewLane.aspx?lane_id=4354&host_id=387&revision_id=857020
Comment 1 Alan McGovern 2017-02-15 00:48:30 UTC
Ludo, maybe this shutdown hang makes sense to you?

https://gist.github.com/alanmcgovern/83df2090ed42697ad75f78e4fd93d88f

It doesn't happen with mono 4.8 so it's most likely a mono regression.
Comment 2 Marek Safar 2017-02-15 08:22:06 UTC
This is quite likely duplicate of #52186. Did you try with macios-2017-02 ?
Comment 3 Ludovic Henry 2017-02-15 14:52:30 UTC
@Marek, what make you say it's a duplicate?
Comment 4 Marek Safar 2017-02-15 16:47:11 UTC
Because without that commit XI simulator was timing out all the time
Comment 5 Rodrigo Kumpera 2017-02-15 17:17:43 UTC
is this a known issue of XS/master?
Comment 6 Vlad Brezae 2017-02-27 20:20:50 UTC
63dde6cce0f8012f20dbcf442d7aff7a8e765cdd fixes a hang that has an identical stacktrace with the ones that kumpera/alan provided. It's worth checking if this issue still exists.
Comment 7 Alan McGovern 2017-03-01 05:22:06 UTC
*** Bug 52918 has been marked as a duplicate of this bug. ***
Comment 8 Ludovic Henry 2017-03-02 21:54:45 UTC
I can't reproduce with latest mono-2017-02. Please reopen if you witness it again. Thank you!