Bug 52446 - UWP app crashes When DynamicResource Used On Label TextColor in Navigation Page
Summary: UWP app crashes When DynamicResource Used On Label TextColor in Navigation Page
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-02-10 15:17 UTC by ebubekirakgul
Modified: 2017-06-20 00:03 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description ebubekirakgul 2017-02-10 15:17:24 UTC
Its a strange bug and took lots of my time.

Scenario : Create a Xamarin.Forms app for UWP platform. Create 3 pages which that pages contains Label with TextColors uses DynamicResource in Xaml. Navigate to Page1->Page2->Page3 then navigate back with 5 minutes delay.


Result : App crashes with "Unknown error"


I think you're trying to reach an object that already deleted by garbage collector.
Comment 1 Paul DiPietro [MSFT] 2017-02-28 17:29:43 UTC
Do you have your reproduction that you can upload to help investigate this? It removes the need to figure out the exact code you're using.
Comment 2 Samantha Houts [MSFT] 2017-06-20 00:03:17 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!