Bug 5242 - Enabling Entitlements for MonoMac / iPhone projects don't persist.
Summary: Enabling Entitlements for MonoMac / iPhone projects don't persist.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 3.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-05-22 12:02 UTC by PJ
Modified: 2012-05-22 16:27 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description PJ 2012-05-22 12:02:18 UTC
Start new monomac app
Open project options
Go to Mac OSX Application
Check 'Enable Entitlements'
Close project options
Open project options again

Expected:

Enable entitlements is still checked

Actual:

Enable entitlements is not checked




Screencast:

http://screencast.com/t/aA1ffDJItxW
Comment 1 PJ 2012-05-22 12:05:21 UTC
Filed this with Jeff here, but for the record:

MD 3.0 (3.0.1)
Mono 2.10.9_11
Comment 2 Jeffrey Stedfast 2012-05-22 14:58:40 UTC
Same for iPhone projects :-(

I swear to god this used to work... but I can't figure out how it ever did.
Comment 3 Jeffrey Stedfast 2012-05-22 16:27:05 UTC
Ok, fixed in git master and 3.0-series branches.