Bug 52408 - [VS-Connected Template] Blank App > Native app fails to compile Droid project in VS2017
Summary: [VS-Connected Template] Blank App > Native app fails to compile Droid project...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: High blocker
Target Milestone: 4.3.0 (C9)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-02-08 21:02 UTC by Ben Beckley
Modified: 2017-03-01 20:52 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
logs (4.47 KB, application/x-zip-compressed)
2017-02-08 21:02 UTC, Ben Beckley
Details
Master Detail Forms logs (7.33 KB, application/x-zip-compressed)
2017-02-08 21:16 UTC, Ben Beckley
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ben Beckley 2017-02-08 21:02:04 UTC
Created attachment 19763 [details]
logs

Reproduction Steps:
1) Start VS2017
2) Go to File > New Project > Cross Platform App
3) Select Blank App / Native
4) Build the Droid project

Actual: Project fails with multiple errors regarding missing mscorlib reference
Expected: Project builds successfully

Xamarin.Forms.Templates.0.5.221/master
build output: https://gist.github.com/BenBeckley/0482654b542b13569259a2c6a61b5cf5
env info: https://gist.github.com/BenBeckley/bff9b30927cd45e72246b238c837ab14
Comment 1 Ben Beckley 2017-02-08 21:16:34 UTC
Created attachment 19764 [details]
Master Detail Forms logs

I believe that this is also happening with Master Detail > Forms (not hosted on cloud).

build output: https://gist.github.com/BenBeckley/c8b1e73e6110b366dca721541c4e2dfd
Comment 3 Niels 2017-02-14 13:26:18 UTC
This also happens for me using Forms.
Comment 5 Daniel Cazzulino 2017-02-14 18:51:46 UTC
Fixed in latest c9 branch VSIXes
Comment 6 Ben Beckley 2017-02-14 22:13:48 UTC
Updated my VS2017 instance with the latest c9 branch VSIXes and found that the failing templates are now building successfully.

XF Templates VSIX: 0.5.235 (master)
env info: https://gist.github.com/BenBeckley/8fcd286dab68b0a6b87fa3a2aad70a06