Bug 52335 - pinvoke3 timeouts on 32bits OSX
Summary: pinvoke3 timeouts on 32bits OSX
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: JIT ()
Version: unspecified
Hardware: PC Mac OS
: Highest normal
Target Milestone: ---
Assignee: Vladimir Kargov
URL:
Depends on:
Blocks:
 
Reported: 2017-02-06 19:21 UTC by Rodrigo Kumpera
Modified: 2017-02-07 20:15 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Rodrigo Kumpera 2017-02-06 19:22:21 UTC
Hi Vladimir,

Please take a look at this one.
Comment 2 Vladimir Kargov 2017-02-07 01:07:19 UTC
It works on the most upstream build https://jenkins.mono-project.com/job/test-mono-mainline/label=osx-i386/5791/.
Should I still investigate?
Comment 3 Rodrigo Kumpera 2017-02-07 07:02:43 UTC
Did you look whether that change explains the change in behavior?

I just looked at it failed after the build you mentioned.
Comment 4 Zoltan Varga 2017-02-07 20:15:52 UTC
Should be fixed by 38ceab15479475d54159de8d2c0d297c56e5f80b.