Bug 52272 - Xamarin Forms ScrollView not working when translation is set
Summary: Xamarin Forms ScrollView not working when translation is set
Status: CONFIRMED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-02-03 13:13 UTC by simon.mengelkoch
Modified: 2017-12-11 14:50 UTC (History)
5 users (show)

Tags: scrollview translation ac uwp
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 52272 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description simon.mengelkoch 2017-02-03 13:13:13 UTC
When the TranslateY property of a ScrollView is set to any Value other than 0, the ScrollView is not scrollable on Windows UWP Desktop via the mouse wheel (only by moving the scroll bar) and there is no way of scrolling on a Windows 10 Emulator (touch and move is not working, the scrollbar is not working too, but i think thats intentional). Android and iOS are working fine.

Here is the testcode from an otherwise clean Xamarin Forms xaml template:

public App()
        {
            InitializeComponent();

            string text = string.Empty;
            for (int i = 0; i < 100; i++)
            {
                text += "text\n";
            }

            MainPage = new ContentPage()
            {
                Content = new ScrollView()
                {
                    TranslationY = 1,
                    Content = new Label()
                    {
                        Text = text
                    }
                }
            };
        }

Result: The ScrollView is not scrollable on Windows 10 UWP Emulator and the mousewheel is not working on Windows 10 UWP. If the TranslateY property is set to 0, it's working fine.
Comment 1 Paul DiPietro [MSFT] 2017-02-27 18:36:58 UTC
Thanks for the reproduction project. Marking as confirmed so we can look into it.
Comment 3 David Ortinau [MSFT] 2017-05-23 19:37:39 UTC
Likely related to https://bugzilla.xamarin.com/show_bug.cgi?id=56170
Comment 4 adam 2017-12-01 17:57:10 UTC
I'm also experiencing this issue when the page that the ScrollView lives within has had it's TranslationX position changed.  Any idea when this may be addressed in an upcoming version of XF? Thanks!