Bug 51827 - Xamarin.Auth incompatible with x64 on UWP
Summary: Xamarin.Auth incompatible with x64 on UWP
Status: RESOLVED FIXED
Alias: None
Product: Components
Classification: Xamarin
Component: Xamarin Components ()
Version: N/A
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Miljenko Cvjetko Mel
URL:
Depends on:
Blocks:
 
Reported: 2017-01-27 12:54 UTC by John Hardman
Modified: 2017-02-10 18:04 UTC (History)
2 users (show)

Tags: x64 UWP Xamarin.Auth
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Hardman 2017-01-27 12:54:49 UTC
Using Xamarin.Auth v1.3.2 in an x64 build for UWP results in the error:

There was a mismatch between the processor architecture of the project being built "AMD64" and the processor architecture of the reference "C:\Users\jh\.nuget\packages\Xamarin.Auth\1.3.2\lib\uap10.0\Xamarin.Auth.dll", "x86". This mismatch may cause runtime failures. Please consider changing the targeted processor architecture of your project through the Configuration Manager so as to align the processor architectures between your project and references, or take a dependency on references with a processor architecture that matches the targeted processor architecture of your project.	

Building as x86 does work, but x64 does not.
Comment 1 John Hardman 2017-01-28 15:25:37 UTC
Similarly, using Xamarin.Auth v1.3.2 in an ARM build for UWP results in a similar message. It would seem that the NuGet package for Xamarin.Auth can not currently cope with 2 out of the 3 likely target platforms for UWP.
Comment 2 Miljenko Cvjetko Mel 2017-02-10 17:20:17 UTC
Hi

Please update nuget package. (And let me know if that fixes the issue, so I can close this bug).

This issue was fixed and published in 1.3.2.1 

https://github.com/xamarin/Xamarin.Auth/issues/141

https://www.nuget.org/packages/Xamarin.Auth/1.3.2.1

Thanks
Comment 3 John Hardman 2017-02-10 18:04:53 UTC
Hi Miljenko,

I can confirm that this is fixed in 1.3.2.1

Many thanks for such a speedy update.