Bug 51825 - I can not input Korean letter in SearchBar.(XF/iOS)
Summary: I can not input Korean letter in SearchBar.(XF/iOS)
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.3.3
Hardware: Macintosh Mac OS
: Normal major
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
: 56712 ()
Depends on:
Blocks:
 
Reported: 2017-01-27 11:59 UTC by Bright Lee
Modified: 2017-12-05 17:21 UTC (History)
8 users (show)

Tags: korean, characters, ios, searchbar, entry, ac fr
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Bright Lee 2017-01-27 11:59:40 UTC
# Steps to reproduce
add SearchBar in forms pcl

# Expected behavior
I should be able to type Korean letter.
(works fine on XF/Android)

# Actual behavior
Korean letter will be divided. (XF/iOS)
(Very serious. It's not even a word when Korean letter is divided.)

# Supplemental info (logs, images, videos)


# Test environment (full version information)
XF 2.3.3:180 
iOS 10.2 simulator/actual device
Comment 1 Paul DiPietro [MSFT] 2017-02-28 18:46:25 UTC
I'm understanding correctly, it looks like the hangul characters are not converting, correct? For example, after typing around a bit with the Korean layout in a Forms app's search bar followed by Safari's search bar, I found that ㅎ ㅜ would convert to 후, but is only doing it in Safari.
Comment 2 Bright Lee 2017-03-01 11:15:20 UTC
Yes. Korean letter can not be created by one letter.
Multiple letters are necessary.

So, in Xamarin, I can't search any Korean word by using a Searchbar.
Comment 3 Paul DiPietro [MSFT] 2017-05-22 01:20:28 UTC
*** Bug 56712 has been marked as a duplicate of this bug. ***
Comment 4 Jorge Pabon 2017-05-22 07:03:59 UTC
Do you have any estimated timeframe when you can look into this? Or how long you would need "as a minimum"? We have an application in production with this bug and need to decide if we reimplement the search with another control, or wait for your fix.
Comment 5 woojung3 2017-09-08 07:12:26 UTC
Same as above. 

Sorry to bother the owner but we really want to know whether the fix will come out soon or not, so that we can decide if we should reimplement the searchbar with another control. 
In bug 56712 (2017-08-16) the owner wrote that he has a fix in place. Has this fix made into source now? If so, when will it be merged into downloadable Xamarin core?

Many thanks for your hard work.
Comment 6 Paul DiPietro [MSFT] 2017-09-08 13:19:08 UTC
The fix is in a branch as mentioned, but I do not anticipate that it would be merged into the 2.4.0 release as we are focused on handling regressions before moving that version to stable. For the time being I imagine you could take the full renderer in the (possible) fix's branch (https://github.com/xamarin/Xamarin.Forms/blob/31dd75402127279a065ebb91e1fefeaa02393b9f/Xamarin.Forms.Platform.iOS/Renderers/SearchBarRenderer.cs) and use it in your iOS project to replace the standard SearchBarRenderer currently present in stable/pre builds. Because it isn't merged, there is always the possibility of unintended side effects.
Comment 7 Samantha Houts [MSFT] 2017-09-11 20:25:04 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1103
Comment 8 Rui Marinho 2017-12-05 17:21:54 UTC
Should be fixed on 2.6.0-pre1