Bug 51665 - [IOS] ListView cell height calculated incorrectly when ContextActions added
Summary: [IOS] ListView cell height calculated incorrectly when ContextActions added
Status: RESOLVED DUPLICATE of bug 51536
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-01-20 16:37 UTC by Serge
Modified: 2017-02-27 18:56 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
sample (10.21 KB, application/x-rar)
2017-01-20 16:37 UTC, Serge
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 51536

Description Serge 2017-01-20 16:37:16 UTC
Created attachment 19415 [details]
sample

ListView cell height calculated incorrectly when ContextActions added. Without context actions height is correct.

Steps to reproduce:
1. run sample in attachement
2. scroll listview or press toolbar item to refresh items -> some cells displayed with white space instead of cell content

3. if you comment line item.ContextActions.Add(ca); in file MyPage.cs, cells are displayed correctly
Comment 1 Oxana 2017-01-29 19:40:01 UTC
+1 also noticed that behaviour in XForms 2.3.4.184-PRE1 (2.3.3 stable is ok)
Comment 2 Matthias 2017-02-13 16:19:55 UTC
Possible duplicate of https://bugzilla.xamarin.com/show_bug.cgi?id=51536
Comment 3 Jimmy [MSFT] 2017-02-27 18:56:56 UTC

*** This bug has been marked as a duplicate of bug 51536 ***