Bug 51538 - UINavigationButton image altered in simulator when using the View Inspector
Summary: UINavigationButton image altered in simulator when using the View Inspector
Status: RESOLVED FIXED
Alias: None
Product: Workbooks & Inspector
Classification: Xamarin
Component: Actually Unsure ()
Version: 1.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: 1.1
Assignee: Bojan Rajkovic [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2017-01-14 20:46 UTC by Chris Riesgo
Modified: 2017-01-18 23:17 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Xamarin version details (1.68 KB, text/plain)
2017-01-14 20:51 UTC, Chris Riesgo
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Riesgo 2017-01-14 20:46:44 UTC
Discovered a bug. Hopefully my explanation helps.

**Steps**

1. Downloaded the Acquaint pre-built app
2. Launched the Acquaint.Native solution in Xamarin Studio
3. Ran an iOS debug build of the app against an iPhone 6s (iOS 10.2) simulator
4. When the app launched, entered a unique key to enter the app
5. Waited for the Acquaintances list to visibly finish loading
6. Launched Inspector by tapping the "Inspect..." button in the XS IDE
7. Once the inspector attached, I tapped the View Inspector button
8. Once the view hierarchy loaded, I tapped the "Select a UI element..."
9. Back in the iPhone simulator, I hovered over and selected the "Settings" (gear) navigation button
10. Back in the Inspector, a UIButton node highlighted in the view hierarchy
11. I selected the first UIImageView control nested within the UIButton
12. The "Settings" (gear) graphic back in the iPhone Simulator became warped
Comment 1 Chris Riesgo 2017-01-14 20:51:05 UTC
Created attachment 19344 [details]
Xamarin version details
Comment 2 Bojan Rajkovic [MSFT] 2017-01-17 16:52:43 UTC
OK, I can reproduce. Thanks for the detailed report! Will look into what's going on here.
Comment 3 Bojan Rajkovic [MSFT] 2017-01-17 23:15:49 UTC
This is fixed. The fix will be in the 1.2 release. Thanks again for the detailed report!
Comment 4 Chris Riesgo 2017-01-17 23:19:48 UTC
Absolutely! Glad I could help, and glad you were able to track it down quickly :)
Comment 5 Aaron Bockover [MSFT] 2017-01-18 23:17:47 UTC
This will actually be fixed in the upcoming 1.1 release.