Bug 51220 - [Profiler-Windows] Unable to take snapshot second time with android application.
Summary: [Profiler-Windows] Unable to take snapshot second time with android application.
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Windows ()
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: (C9)
Assignee: Jose Miguel Torres
URL:
: 49319 52064 ()
Depends on:
Blocks:
 
Reported: 2017-01-04 16:39 UTC by asimk
Modified: 2017-02-15 12:14 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: No
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 asimk 2017-01-04 17:36:00 UTC
Here is the android logcat for the same: https://gist.github.com/Asimk360/b0fb7c147692775754b54233f3e4107c
Comment 2 Jose Medrano 2017-01-16 19:12:04 UTC
*** Bug 49319 has been marked as a duplicate of this bug. ***
Comment 3 Jose Miguel Torres 2017-01-23 17:43:29 UTC
Fixed in master. XamarinProfiler.Windows.Installer.1.1.99-280.msi
Comment 4 Akhilesh kumar 2017-01-25 11:13:27 UTC
I have checked this issue with master XamarinProfiler.Windows.Installer.1.1.99-280 and I am still observing this issue. After taking snapshot FIRST time, take snapshot icon get disabled and  we are unable to take snapshot further.

Screencast: https://www.screencast.com/t/XxD5zxGDbBKi

XamarinProfiler.Windows.Installer.1.1.99-280_37427a1df6331dce205c0e4874f643592e06e1a4

Profile log: https://gist.github.com/AkhileshKumar01/3a7beb250b7a16d6ba56d9f2ed69b354

So I am reopening this issue.
Comment 5 Jose Medrano 2017-01-31 16:02:05 UTC
*** Bug 52064 has been marked as a duplicate of this bug. ***
Comment 6 Akhilesh kumar 2017-02-15 12:14:20 UTC
I have checked this issue with latest C9 profiler builds and now I am successfully able to take snapshot by clicking on take snapshot button.

Screencast: https://www.screencast.com/t/7vIq4VaP

Xamarin Profiler 1.2.0.0_ 5c8e059ac05fff0fd06c69f589c0d9f26168ead1

So I am closing this issue.

Thanks!