Bug 51135 - Xamarin Android Builds extremely slow
Summary: Xamarin Android Builds extremely slow
Status: RESOLVED DUPLICATE of bug 44622
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 6.1.2 (C7SR1)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2016-12-29 09:02 UTC by Mauro P.
Modified: 2017-01-03 11:37 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Build Output (278.35 KB, text/plain)
2016-12-29 09:02 UTC, Mauro P.
Details
BuildOutput-Diagnostic (1.57 MB, text/plain)
2016-12-29 14:57 UTC, Mauro P.
Details
BuildOutput-Diagnostic, Acquaint (2.51 MB, text/plain)
2016-12-29 14:58 UTC, Mauro P.
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44622

Description Mauro P. 2016-12-29 09:02:18 UTC
Created attachment 19022 [details]
Build Output

Version: Xamarin Studio 6.1.3 (build 19)

In last versions very often (not always but 99% of the times) the build process is very low, and this only for Android project (pcl build is extremely fast).
I cannot find a pattern in this behaviour.
I incremented Java Heap space to 2GB, I tried with and without Shared Mono Runtime, with and without Fast Assembly Deployment.
A couple of weeks ago I enabled Multi-Dex and upgraded target API SDK to 24 (and Support Library too), but only in last few days I started to see the problem.
Almost always between 3 and 5 minutes of build also when I don't change anything, it's starting to be frustrating and my productivity is like dead...

I wrote also here https://bugzilla.xamarin.com/show_bug.cgi?id=44622 but I guess the assignee disappeared because in three months he didn't write anything.
Comment 1 Mauro P. 2016-12-29 14:57:56 UTC
Created attachment 19031 [details]
BuildOutput-Diagnostic

Diagnostic BuildOutput of my project, always around 4 minutes.
Comment 2 Mauro P. 2016-12-29 14:58:52 UTC
Created attachment 19032 [details]
BuildOutput-Diagnostic, Acquaint

Diagnostic build output of the project Acquaint
Comment 3 dean.ellis 2017-01-03 11:37:53 UTC

*** This bug has been marked as a duplicate of bug 44622 ***