Bug 5087 - XML comment generation appears to have a regression bug
Summary: XML comment generation appears to have a regression bug
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-05-15 08:48 UTC by James Bright
Modified: 2012-05-26 02:26 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description James Bright 2012-05-15 08:48:25 UTC
Reference:
http://stackoverflow.com/questions/10517210/in-monodevelop-how-do-you-turn-off-the-verbose-comment-generation-when-typing

In the previous version of MonoDevelop, if you typed in '///' it would autogenerate the xml comment block along with placeholder text. If you didn't want the additional placeholder text, you could use your hot-key for UNDO and you'd end up with:

    /// <summary>
    /// 
    /// </summary>
    /// <param name="bar"></param>
    public void Foo(string bar)
    {
    }  

(This is the normal VisualStudio experience). 

After getting MD 3.0, when you use the UNDO hot key, it reverts back to '///'. This is loss of functionality and generally makes some developers sad.
Comment 1 Mike Krüger 2012-05-16 02:18:45 UTC
Already fixed in the master branch.
Comment 2 Mikayla Hutchinson [MSFT] 2012-05-17 15:26:45 UTC
Confirmed that undo removes the placeholder text in master, however, a second undo now takes it back to "//" not "///".
Comment 3 Mike Krüger 2012-05-17 15:37:58 UTC
the 2nd step is another bug and surely no regression.

But right, that the 2nd undo should take it back to ///.

fixed.
Comment 4 James Bright 2012-05-25 20:49:40 UTC
What version is this fixed in? I just applied the latest (3.0.2) and wasn't sure if this fix was in. 

In this version if I type "///" I get:

		/// <Docs>
		/// Called when the controller’s view is released from memory. 
		/// </Docs>
		/// <summary>
		/// Views the did unload.
		/// </summary>
		public override void Foo ()

and if I do one level of undo, I get 

		//
		public override void Foo ()

Previously after one undo, I'd be left with

		/// <summary>
		/// 
		/// </summary>
		public override void Foo ()

And then a second undo would go back to plain "///"

Thanks.
Comment 5 Mike Krüger 2012-05-26 02:26:21 UTC
It's fixed in 3.1