Bug 5041 - Refreshing ASMX web service doesn't refresh method signatures for use
Summary: Refreshing ASMX web service doesn't refresh method signatures for use
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Web Services ()
Version: 2.8.8.4
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2012-05-12 10:41 UTC by Neal
Modified: 2013-12-09 05:05 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Patch to broadcast file notification after update (1.80 KB, patch)
2012-05-14 19:58 UTC, Mikayla Hutchinson [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2012-05-12 10:41:27 UTC
Hello,

I have an ASMX web service, I added new methods on the server and then selected the web service in MD 2.8.8.4 / MT 5.2.11 and selected Update Service to pull in the new methods.  Intellisense does not see the new method signatures available, it still has the old methods cached.  I verified on the disk that the Reference.cs was updated and it was, I had to close and reopen MD for the updated service references to load.
Comment 1 Mikayla Hutchinson [MSFT] 2012-05-14 19:37:11 UTC
It looks like the web services addin isn't firing a file change notification event after it updates the proxy class file. I have a patch for this but I can't test it without a modifiable web service....
Comment 2 Mikayla Hutchinson [MSFT] 2012-05-14 19:58:24 UTC
Created attachment 1884 [details]
Patch to broadcast file notification after update
Comment 3 Marius Ungureanu 2013-12-09 05:05:55 UTC
Tested the patch. It works and I've commited and pushed it.