Bug 50357 - ItemTapped and ItemSelected Events are not fired in Release mode in UWP platform
Summary: ItemTapped and ItemSelected Events are not fired in Release mode in UWP platform
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Windows ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 50416 ()
Depends on:
Blocks:
 
Reported: 2016-12-19 08:54 UTC by Dinesh
Modified: 2016-12-29 21:26 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Events are not fired in ListView in UWP platform in release mode (297.62 KB, application/zip)
2016-12-19 08:54 UTC, Dinesh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Dinesh 2016-12-19 08:54:53 UTC
Created attachment 18917 [details]
Events are not fired in ListView in UWP platform in release mode

Hi Team,

ItemTapped and ItemSelected events are not fired when item is tapped or selected in ListView in UWP platform in Release mode but in debug mode it is working like expected. 
I have tested in UWP nuget version : 5.0.0 and Build version : 10240
For your reference I have attached the sample too. 

Regards,
Dinesh Babu Yadav
Comment 1 Paul DiPietro [MSFT] 2016-12-29 21:07:28 UTC
*** Bug 50416 has been marked as a duplicate of this bug. ***
Comment 2 Paul DiPietro [MSFT] 2016-12-29 21:26:45 UTC
I added a simple DisplayAlert call into one of the events (ItemTapped) on this project and it works as expected in Release mode. The events in the reproduction are empty, so I'm not sure what the expected result is here. At any rate I'm not seeing an issue and marking this as closed. If there are reproducible steps to concretely recreate the issue then please feel free to reopen this.