Bug 5023 - Assembly Browser fails to show nested classes.
Summary: Assembly Browser fails to show nested classes.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Assembly browser ()
Version: Trunk
Hardware: PC Linux
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-05-11 04:50 UTC by Atsushi Eno
Modified: 2012-05-21 07:53 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Atsushi Eno 2012-05-11 04:50:04 UTC
Compile the simple test case below (mcs -t:library test.cs), and open the assembly in MD assembly browser:

using Object = System.Object;

namespace Foo
{
	public class Bar : Object
	{
		public class Baz : Object
		{
		}
	}
}

It only shows Foo.Bar class. Foo.Bar.Baz is not shown.

(Bug #4705 uncovered this issue.)
Comment 1 Mike Krüger 2012-05-21 07:53:03 UTC
fixed.