Bug 49897 - Cross Platform App Templates UWP doesn't get built or deployed by default.
Summary: Cross Platform App Templates UWP doesn't get built or deployed by default.
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: Normal normal
Target Milestone: 4.4.0 (C10)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-12-13 17:50 UTC by James Montemagno [MSFT]
Modified: 2016-12-28 12:09 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description James Montemagno [MSFT] 2016-12-13 17:50:02 UTC
In any cpu and debug it should get built and deployed.

If you open the configuration manager only android is set to build and deploy.
Comment 1 Kyle White 2016-12-14 17:10:42 UTC
Hey James, I'm pretty sure AnyCPU is not supported for UWP apps, thus you need to select a specific CPU platform (x86 or x64).

Buried in here https://msdn.microsoft.com/en-us/library/Mt148501.aspx you will find:
 > AnyCPU is not supported for Windows 10 apps in Visual Studio 2015.

I also found https://social.msdn.microsoft.com/Forums/en-US/3ac58e63-f4aa-4a5b-82a2-2cfaf2465ec5/known-issue-cvb-uwp-apps-do-not-support-anycpu-windows-10-insider-preview-sdk-and-tools-april?forum=Win10SDKToolsIssues
Comment 2 Kyle White 2016-12-14 17:26:21 UTC
Just checked what you get unfolding a regular UWP project. Only ARM, x86 and x64 platform configs (no AnyCPU).
Comment 3 Joaquin Jares 2016-12-28 12:09:03 UTC
Yep, Kyle is right. UWP will not build on AnyCPU. I'm marking as Invalid, but please do reopen if you feel we should be doing anything about it.