Bug 4984 - [Designer] Cannot open designer unless you are in the first MFA solution opened during VS instance
Summary: [Designer] Cannot open designer unless you are in the first MFA solution open...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.1.x
Hardware: PC Windows
: --- major
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-05-09 19:20 UTC by PJ
Modified: 2013-02-28 16:56 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Log from Case #27070 (2.48 KB, application/octet-stream)
2013-02-28 14:41 UTC, Allie Miller
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description PJ 2012-05-09 19:20:56 UTC
If you try, you will get http://screencast.com/t/v0ZREDqH6Mz (The operation could not be completed. Invalid Pointer)



Steps to reproduce:

Open VS
Create an MFA project
Create a second MFA project
Double click the .axml file in Resources/Layout

Expected result:

Designer should open

Actual result:

http://screencast.com/t/v0ZREDqH6Mz

Workaround: Restart VS

Setting severity to major because it looks pretty bad. Not setting it higher because there is a workaround and many users will just be editing one solution.
Comment 2 Duncan Mak 2012-05-09 20:13:04 UTC
Here's the build log to RC4:

https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=383910

checkout git@github.com:xamarin/AndroidVS to c:\cygwin\tmp\source/AndroidVS at 8d8783e19e14587bb9e9f959b30942ce5921180d

So RC4 contains the 9a6a8f7c commit.
Comment 3 PJ 2012-05-09 20:30:10 UTC
This was found on RC4 of MFA  4.2 (sorry for not including).

Running mandroid.exe --version and sending the output to a text file I get: monodroid 4.2.0.160383603 


That's the right output so something is still occurring that shouldn't be.
Comment 4 Jonathan Pobst 2012-05-10 12:06:35 UTC
My bad, I misunderstood what this bug was about.

Fixed in aa4d4b76ef6b29cc742488536e96868eb90f3a83.
Comment 5 PJ 2012-05-11 05:41:36 UTC
Verified fixed in MFA 4.2.0 RC5
Comment 7 Allie Miller 2013-02-28 14:41:08 UTC
Created attachment 3514 [details]
Log from Case #27070