Bug 4983 - [Designer] Double clicking a widget with a text property opens up textbox for editing but does not focus that textbox
Summary: [Designer] Double clicking a widget with a text property opens up textbox for...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Designer ()
Version: 4.1.x
Hardware: PC Windows
: --- trivial
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-05-09 18:54 UTC by PJ
Modified: 2012-05-11 05:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description PJ 2012-05-09 18:54:48 UTC
VS 2010
MFA 4.2 RC4 

Steps to reproduce:

Add a button to a layout
Double click the button to open the text/resource editor


Expected:
Textbox text is selected (MD behavior) or the box at least has focus

Actual:
Text box does not gain focus



Workaround:

Press tab twice and the box gains focus (but text does not select like MD).
Comment 1 PJ 2012-05-09 20:13:02 UTC
While the assignation is correct - this issue does not occur on MD so I am putting back into MFA/VS (as that's where the code lives).

If you think that's incorrect definitely let me know, but otherwise you'll be changing the product on a number of bugs.

Bugs that were for both I tried to file in MD/Designer with a line saying that it affects VS as well.
Comment 2 PJ 2012-05-11 05:30:57 UTC
Verified fixed in MFA 4.2.0 RC5.

New behavior puts cursor at the beginning of the default string. Filed an enhancement about the consistency of this behavior between VS and MD on this now (bug 5026).