Bug 49804 - [UI review] Inspector views
Summary: [UI review] Inspector views
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Mac ()
Version: 1.0.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: (C9)
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2016-12-13 11:31 UTC by Rodrigo Moya
Modified: 2017-01-05 11:58 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Rodrigo Moya 2016-12-13 11:31:09 UTC
In allocations pie chart:

* Use a pointing hand cursor when hovering over this chart to indicate the slices are clickable.
* Highlighting slices on hover will help too.
* Base on Xamarin/Microsoft colour palette.

General:

The details sidebar (inspector view) background colour looks too dark. Try normal window background colour.
Comment 1 Luis Aguilera 2016-12-19 16:00:48 UTC
these bug fixes did not make the date cut-off for C8SR2, hence they'll be targeted for the C9 milestone.
Comment 2 xamarin-release-manager 2017-01-03 17:51:30 UTC
Fixed in version 1.1.99.200 (master)

Author: Jose?? Miguel Torres
Commit: b2faafe48fd81df3f5f8abd82e29f67b627e1228 (xamarin/profiler)
Comment 3 Naqeeb 2017-01-03 19:21:38 UTC
I have checked this issue with latest master build i.e. profiler-mac-1.1.99-200  and observed that it is working fine. Here is the screencast for the same: https://www.screencast.com/t/n7fl2MIimY

Environment info: https://gist.github.com/saurabh360/6e5992af191cd184a3b9b5440e57a038

I will verify once, when fix with C9 build.

Thanks!
Comment 4 Naqeeb 2017-01-05 11:58:20 UTC
I have checked this issue with latest C9 build i.e. profiler-mac-1.1.4-16_d6cc81a589f4b6befd0201a450e7b4febe9d5ad5  and observed that it is working fine. Here is the screencast for the same: https://www.screencast.com/t/IYr46YmHpK8P

Environment info: https://gist.github.com/NaqeebAnsari/eba15b7d4476d566138eb2a828a013cd

Hence closing this issue.