Bug 49797 - [UI review] Switching instruments is slow
Summary: [UI review] Switching instruments is slow
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Mac ()
Version: 1.0.x
Hardware: PC Mac OS
: High normal
Target Milestone: (C9)
Assignee: Rodrigo Moya
URL:
Depends on:
Blocks:
 
Reported: 2016-12-13 11:16 UTC by Rodrigo Moya
Modified: 2017-01-30 17:12 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Rodrigo Moya 2016-12-13 11:16:52 UTC
Switching instruments feels slow and unresponsive. Could be fixed by immediately highlighting the newly selected instrument and adding a spinner or other progress indicator.
Comment 1 Luis Aguilera 2016-12-19 16:00:50 UTC
these bug fixes did not make the date cut-off for C8SR2, hence they'll be targeted for the C9 milestone.
Comment 2 xamarin-release-manager 2017-01-20 19:58:48 UTC
Fixed in version 1.1.99.280 (master)

Author: Rodrigo Moya
Commit: 72da5b3a19b5b3c3a3c29f21ff33e7931fd9e3d4 (xamarin/profiler)
Comment 3 narayanp 2017-01-25 19:07:07 UTC
I have checked this issue with latest Master 1.1.99.285 Xamarin.Profiler build and observe that now switching instrumentation feels responsive.

Screencast: https://screencast.com/t/wyT9aLFJn95K
Comment 4 Shruti 2017-01-27 06:32:14 UTC
Please merge the fix of this issue in C9 release branch.
Comment 5 asimk 2017-01-30 17:12:39 UTC
This issue has been fixed with latest C9 build i.e. 1.1.7.4
Screencast: https://www.screencast.com/t/1CVxNS2Y

Thanks!