Bug 49424 - Vs2013 crashes when a breakpoint is hit in an Android app.
Summary: Vs2013 crashes when a breakpoint is hit in an Android app.
Status: RESOLVED NORESPONSE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 4.2.0 (C8)
Hardware: PC Windows
: Normal normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-12-09 10:40 UTC by anton.duzenko@gmail.com
Modified: 2017-07-05 19:23 UTC (History)
5 users (show)

Tags: BZCU
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot (116.81 KB, image/png)
2016-12-09 10:40 UTC, anton.duzenko@gmail.com
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description anton.duzenko@gmail.com 2016-12-09 10:40:36 UTC
Created attachment 18848 [details]
screenshot

I have an app that I am debugging on a Android 6.0 phone.
When a breakpoint is hit in the app, vs2013 stops on it and immediately crashes.
If it helps, the breakpoint is hit by a code running in a background thread rather than the UI thread.
Comment 1 Ashley Gazich [MSFT] 2017-01-06 22:51:51 UTC
Hello, thank you for submitting this report. Could you please provide the following?

1. Minimized runnable test case demonstrating the issue
2. Steps to reproduce
3. Call stack of Visual Studio's Main Thread https://developer.xamarin.com/guides/cross-platform/getting_started/visual_studio_with_xamarin/troubleshooting/vs-callstack/
4. Full version information from Visual Studio: Help > About Microsoft Visual Studio > Copy Info [button]


Thank you!
Xamarin Support
Comment 2 anton.duzenko@gmail.com 2017-01-10 12:19:03 UTC
Right now I can't install Xamarin for vs2013 at all.
I.e. installer completes successfully, but nothing xamarin-related shows in Visual Studio.
Comment 3 Ashley Gazich [MSFT] 2017-01-12 18:18:05 UTC
Since installation is a separate issue, let's move that discussion from the Xamarin bug tracking system to a support avenue. Once installation is taken care of, we can revisit this report with additional details if the issue persists. 

Support via Xamarin account: https://store.xamarin.com/account/my/subscription
Xamarin support options: https://developer.xamarin.com/guides/cross-platform/troubleshooting/support-options/

Installer logs, the full text of any error messages encountered, and any additional information you can provide about steps taken and problematic behavior would be helpful in planning our next steps. Please see https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/version-logs/.
Comment 4 Ashley Gazich [MSFT] 2017-01-12 18:31:55 UTC
Anton, here are some installation resources to help. My apologies for not including them in my earlier comment.

- Requirements (minimum non-Express Visual Studio 2013 Update 2) https://developer.xamarin.com/guides/cross-platform/getting_started/requirements/#Windows_Requirements
- Installation https://developer.xamarin.com/guides/cross-platform/getting_started/installation/
- Xamarin for Visual Studio Troubleshooting https://developer.xamarin.com/guides/cross-platform/getting_started/visual_studio_with_xamarin/troubleshooting/
Comment 5 anton.duzenko@gmail.com 2017-01-13 09:28:57 UTC
Sorry, what am I supposed to do with the installation issue?
Ask about it on Stackoverflow or what?
Comment 6 Joaquin Jares 2017-06-28 14:51:47 UTC
Was the installation issue ever resolved?
Comment 7 Ashley Gazich [MSFT] 2017-07-05 19:23:11 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin. If you are still experiencing the issue after updating your installation, please open a new report with the attached information requested in Comment 1.