Bug 4934 - Create member command broken for enum
Summary: Create member command broken for enum
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-05-07 17:04 UTC by Mikayla Hutchinson [MSFT]
Modified: 2012-05-08 00:51 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mikayla Hutchinson [MSFT] 2012-05-07 17:04:49 UTC
The Create Property command on an missing enum value creates a property, which is invalid. It should add a value to the enum.
Comment 1 Mike Krüger 2012-05-08 00:51:43 UTC
It shouldn't create a property for enums.
The create property code action is specialized in created properties. 

For the enum case a create enum member action is missing.

I had similiar issues with other create commands + enums - I hope I've found them all.