Bug 4933 - Enum completion in switch statements no longer works
Summary: Enum completion in switch statements no longer works
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-05-07 17:04 UTC by Mikayla Hutchinson [MSFT]
Modified: 2012-05-08 13:59 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Mikayla Hutchinson [MSFT] 2012-05-07 17:04:09 UTC
Enum completion in switch statements no longer works.
Comment 1 Mike Krüger 2012-05-08 00:52:40 UTC
Works for me do you've a case/screencast ?
Comment 2 Mikayla Hutchinson [MSFT] 2012-05-08 13:27:11 UTC
I can't reproduce it in the exact same place and build now. Must have been caused by some intermediate strange AST or type context state.
Comment 3 Mike Krüger 2012-05-08 13:59:47 UTC
Reopen if the bug persists. It's not easy to get an invalid type system state.
Lately I did some loading changes where out of sync document <-> ts could've happen during project load.

But I think I've fixed that in the current master. (but in that case red names should've shown up - when nothing is red the type system works :))

AST state is much more likely that's why I need the exact use case. 

Reopen, if it happens again.