Bug 49281 - TabbedPage is firing OnAppearing twice on first children page
Summary: TabbedPage is firing OnAppearing twice on first children page
Status: RESOLVED DUPLICATE of bug 44211
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.3
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-12-08 08:36 UTC by Pawel Kanarek
Modified: 2016-12-16 17:49 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 44211

Description Pawel Kanarek 2016-12-08 08:36:28 UTC
Starting the app with TabbedPage as Application.MainPage leads to Fire OnAppearing, OnDisappearing and again onAppearing on first tab page. This is output from my sample project 

[0:] MainTabbedPage Constuctor
[0:] TestTab1 Constuctor
[0:] TestTab2 Constuctor
[0:] TestTab3 Constuctor
[0:] TestTab4 Constuctor
[0:] MainTabbedPage OnAppearing
[0:] TestTab1 OnAppearing
[0:] TestTab1 OnDisappearing
[0:] TestTab1 OnAppearing

There should be only one OnAppearing() call. 

Sample project:
https://github.com/PawKanarek/XamarinTabbedPage
Comment 1 adrianknight89 2016-12-10 22:58:54 UTC
There is already a PR for this: https://github.com/xamarin/Xamarin.Forms/pull/354
Comment 2 TimeSlice 2016-12-16 16:24:56 UTC
I can confirm the same misbehavior
Comment 3 Paul DiPietro [MSFT] 2016-12-16 17:49:53 UTC

*** This bug has been marked as a duplicate of bug 44211 ***