Bug 49242 - Paths to roots is blank
Summary: Paths to roots is blank
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: High normal
Target Milestone: (C9)
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2016-12-07 18:13 UTC by Jeremy Kolb
Modified: 2017-02-03 11:38 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
zipped up mlpd file (1.56 MB, application/x-zip-compressed)
2016-12-08 15:26 UTC, Jeremy Kolb
Details
Profiler log (19.97 KB, text/plain)
2016-12-08 15:27 UTC, Jeremy Kolb
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jeremy Kolb 2016-12-07 18:13:30 UTC
The profiler has paths to roots as blank for live objects.
Comment 1 asimk 2016-12-08 14:15:12 UTC
@jkolb, I have checked this issue with latest profiler build i.e. 1.1.2.0 and unable to reproduce this issue.
Could you please attach the sample and profiler log so that I can confirm this issue at our end.

Screencast: http://www.screencast.com/t/iQ5fwEIO
Comment 2 Jeremy Kolb 2016-12-08 15:26:36 UTC
Created attachment 18829 [details]
zipped up mlpd file
Comment 3 Jeremy Kolb 2016-12-08 15:27:07 UTC
Created attachment 18830 [details]
Profiler log
Comment 4 Jeremy Kolb 2016-12-08 15:27:51 UTC
This is with build 1.0.2.2.  It does not appear that 1.1.2.0 is on the Xamarin site.
Comment 5 Jeremy Kolb 2016-12-08 15:29:26 UTC
The project is at https://github.com/inormis/MvxSIGSEVTest
Comment 6 Rodrigo Moya 2016-12-12 13:34:01 UTC
You need to take snapshots (and wait for the application to finish) to see data in the paths to roots section, as that's where object references are reported by the runtime. So:

* start profiling your app
* take as many snapshots as you want
* stop application

After that, you should see data for alive objects
Comment 7 Jeremy Kolb 2016-12-12 15:01:22 UTC
Even with snapshots via GC (example if I set it to snapshot on every GC or every 10 seconds) it does not work.
Comment 8 Jeremy Kolb 2016-12-12 15:01:47 UTC
Manual snapshots are not possible.  See Bug 49319.
Comment 9 Rodrigo Moya 2017-02-02 19:12:58 UTC
this should be fixed now in the upcoming C9 refresh (1.1.8), so closing for now, please reopen if it happens again for you.
Comment 10 Akhilesh kumar 2017-02-03 11:38:58 UTC
I have checked this issue with latest profiler build i.e. 1.1.8.65 and  observed that this issue is working fine.

Screencast:https://www.screencast.com/t/hVqLCIkCqTm2

Now I am closing this issue.
Thanks!