Bug 49160 - Inform user when attempting build that XMA hasn't finished yet.
Summary: Inform user when attempting build that XMA hasn't finished yet.
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: 4.3.0 (C9)
Hardware: PC Windows
: --- normal
Target Milestone: 15.4
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2016-12-06 22:46 UTC by Pierce Boggan [MSFT]
Modified: 2017-07-27 11:23 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Pierce Boggan [MSFT] 2016-12-06 22:46:32 UTC
In situations where the Xamarin Mac agent hasn't finished connecting yet (such as after a reboot of Visual Studio, disconnection, etc.), we currently display "Starting Xamarin Mac Agent..." in the bottom-left corner. Often, new users don't know it's there, or that they have to wait for it.

If a user attempts to build an iOS solution BEFORE the XMA has finished booting up all processes (and XMA icon is green), we should display a helpful error letting them know to wait for the XMA to finish connecting before continuing.
Comment 1 mag@xamarin.com 2016-12-22 19:32:14 UTC
Confirming and assigning to cycle10 for further investigation and to provide a proper solution
Comment 2 xamarin-release-manager 2017-06-28 20:23:50 UTC
Fixed in version 4.7.0.697 (xma-refactoring)

Author: Mauro Agnoletti
Commit: 243bb29b53b42432ca9396a22e67bd0e8c11a1bd (xamarin/XamarinVS)
Comment 3 mag@xamarin.com 2017-06-28 20:26:55 UTC
There were many improvements about the messages that we show to the user when a build is not fully executed because the connection to the Mac is not active or fully operational. However, those messages appears only on the errors pane.

Even if that already adds to the purpose of this Bug, I also added a warning message both on the status bar and the Xamarin output pane, to make the user suggestion more visible.

So the behavior now is that if the user builds when XMA is connecting, he will see a warning message on the status bar, output pane and errors pane. On the errors pane they will appear as soon as the build ends.

As it happens when the build is performed offline, it will complete locally but not fail, which is correct.