Bug 49057 - Map Camera is reseted to default location whe it is in tabbed page
Summary: Map Camera is reseted to default location whe it is in tabbed page
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.1
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Paul DiPietro [MSFT]
URL:
: 52185 ()
Depends on:
Blocks:
 
Reported: 2016-12-05 22:15 UTC by paukert.michal
Modified: 2017-03-16 19:26 UTC (History)
3 users (show)

Tags: map camera reset
Is this bug a regression?: ---
Last known good build:


Attachments
map camera bug (3.87 MB, image/gif)
2016-12-05 22:15 UTC, paukert.michal
Details
Project with induced bug. (291.67 KB, application/x-zip-compressed)
2016-12-26 08:48 UTC, paukert.michal
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description paukert.michal 2016-12-05 22:15:55 UTC
Created attachment 18780 [details]
map camera bug

Hello,
When I create app with xamarin.forms.map and map is in tabbed page camera is reseted to default location after i click on 3rd tab.
I am able to provide solution how to induce, but I think it is not problem to create tabbed page with 3 pages.
Comment 1 adrianknight89 2016-12-07 19:10:03 UTC
I tried to duplicate this in AppCompat / S6, but I could not. Can you try 2.3.3.175?
Comment 2 paukert.michal 2016-12-07 21:25:27 UTC
I am still able to induce on emulator API 19.
I packed my solution where I am able to induce: https://www.dropbox.com/s/ge8tgy3otzy7bm0/Test.zip?dl=0 please try it
Comment 3 paukert.michal 2016-12-26 08:48:35 UTC
Created attachment 18992 [details]
Project with induced bug.

Project with induced bug.
Comment 4 paukert.michal 2017-01-21 13:53:48 UTC
I sent pullrequest to Xamarin.Forms.GoogleMaps project https://github.com/amay077/Xamarin.Forms.GoogleMaps/pull/172 which is fixing this issue.
Comment 5 Paul DiPietro [MSFT] 2017-03-16 19:07:56 UTC
The reproduction appears to be missing a solution file. If this is still occurring, please try using this platform specific API here to see if it helps alleviate the issue, as I suspect it could have something to do with your problem: https://developer.xamarin.com/api/type/Xamarin.Forms.PlatformConfiguration.AndroidSpecific.TabbedPage/
Comment 6 paukert.michal 2017-03-16 19:09:34 UTC
Issue was fixed by this PR https://github.com/amay077/Xamarin.Forms.GoogleMaps/pull/212/files
Comment 7 Paul DiPietro [MSFT] 2017-03-16 19:10:53 UTC
*** Bug 52185 has been marked as a duplicate of this bug. ***
Comment 8 Paul DiPietro [MSFT] 2017-03-16 19:26:36 UTC
Thank you for the information. In the future please do try to avoid refiling duplicate issues and to update these bugs if they end up externally resolved.