Bug 4895 - ALINK: error A1010: Missing ':<text>' for 'culture' option
Summary: ALINK: error A1010: Missing ':<text>' for 'culture' option
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: Trunk
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-05-04 17:55 UTC by Ian
Modified: 2017-08-22 20:01 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project (3.00 MB, application/zip)
2012-05-04 17:55 UTC, Ian
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Ian 2012-05-04 17:55:30 UTC
Created attachment 1807 [details]
Sample project

When trying to build the attached simple project, I get this unexpected error:

Building Solution: Portal.iOS (Debug|iPhoneSimulator)

Building: Common.Portal.iOS (Debug)
Performing main compilation...
Generating satellite assembly for '' culture with al
Unable to generate satellite assemblies for '' culture with al.
Reason: 
ALINK: error A1010: Missing ':<text>' for 'culture' option
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-05-04 18:08:44 UTC
It looks like the file "Data/Albanian/Besimi Bahá'í dhe takimi i nivelit të lartë për aleancën midis feve dhe ruajtjen mjedisit.txt" is for some reason treated as EmbeddedResource, even if shows up in MD as Content.

There are in fact no EmbeddedResources at all in the project, so there shouldn't be any satellite assemblies to generate at all.

=> MonoDevelop.
Comment 2 Ian 2012-05-05 15:47:16 UTC
Moving the /Data folder with the Unicode (UTF-8) files back to the main project got rid of the error.

However, the Data files need to be in a common folder as we are building MonoDroid and MonoTouch apps based on a common Mono library. We have bought both licenses.
Comment 3 Will Smith 2017-08-22 20:01:49 UTC
Thanks so much for taking the time to submit this report! I attempted to reproduce this issue based on the bug description with the latest Visual Studio 2017 for Mac Preview version 7.2, and I was unable to hit the problem. If this issue is still occurring for you, please reopen this report and attach a reproduction, ideally starting with a new template project and then adding just the code necessary to demonstrate the issue.